Nos projets
Bot
Autres

Installer Shadow Linux et Chrome book

Pour installer l'application Linux, téléchargez l'AppImage du site, mettez les droits d'exécution, mettez la dans un endroit confortable et lancez là. Nous vous conseillons l'AppImage plutôt qu'un autre packaging. Les AppImage sont accessibles depuis votre espace membre. Pour installer votre GPU correctement, suivez les informations.

Correctif 1

Pour ceux présentant un stream coloré du plus bel effet (ex: que des variantes de rouge), ceci est dû à une mauvaise utilisation des drivers par votre OS. Pour le régler, exécutez la commande suivante, et relancez l'application.

curl https://gitlab.com/NicolasGuilloux/shadow-live-os/raw/arch-master/airootfs/etc/drirc -o ~/.drirc

Plus d'info ici : https://nicolasguilloux.github.io/blade-shadow-beta/issues#the-drirc-fix Source : Discord Shadow

Correctif 2

Une nouvelle mise à jour a eu lieu hier, le 26 août, et apporte le Quick Menu. Si vous rencontrez des problèmes, merci bien vouloir : 1. Vérifier que libva-glx2 est installé sur votre machine 2. Si vous rencontrez toujours des problèmes, veuillez activer l'option "Faible Configuration" (et non faible connexion !). Celle-ci va désactiver le Quick Menu, il est possible que votre GPU ne le supporte pas. 3. Partagez nous le lien retourné par cette commande : curl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/scripts/report.pl | perl 4. Pinguez moi ou un dev qu'on récolte vos rapports Source : Discord Shadow

Installation

Shadow is compatible with the following OS and their more recent versions:

​Ubuntu 18.04, Linux Mint 19, Debian 10, Arch Linux, Solus, Fedora 28, GalliumOS 3.0.

If your OS meets the minimum version, lets get started! Please download the official AppImage.

You may pick the one you prefer based on your liking but keep in mind that the Linux app is not under very active development, which means sometimes it may break even in Stable and a fix may be deployed only on Alpha or Beta. We recommand your to download them all, and change if you meet a blocking bug.

You now have the AppImage. Make it executable and start it to check that the launcher is here. Sadly, it is rarely click'n'play.

Shadow is not compatible with Wayland! Use Xorg instead.

For every user who wants the remember me feature, you need to install gnome-keyring.

On Arch Linux, Shadow requires libsndio-61-compat.

For Fedora users, you may need to install the library librtmp.

For Ubuntu 20.04+ users, you may need to install the following driver for Intel GPUs intel-media-va-driver-non-free.

The community built a wonderful report script that gather all information to debug quickly your setup. Everytime you ask for help, please join the link given back the following command:

curl https://raw.githubusercontent.com/NicolasGuilloux/blade-shadow-beta/master/scripts/report.pl | perl

Setup you GPU for the VA-API

As Shadow for Linux uses the VA-API, it is important to well setup your GPU for it. So it is important to understand how worksvainfo and how to debug it.

First things first, vainfo needs to be installed on your OS. It is a program that describes how your GPU is detected by the VA-API.

  • Debian: sudo apt install libva-glx2 vainfo

  • Arch Linux: sudo pacman -S libva-utils

  • Solus: sudo eopkg it libva-utils

Vainfo scans your GPU with the given driver to check his abilities. There are 3 things to check from the result of the command:

  • If it returns nothing or returns -1 somewhere, it means that the GPU is not well detected. Your VA driver needs to be updated.

  • In the list of profiles, it mentions "H264" at least once. If supported, you can use the Shadow on Linux.

  • In the list of profiles, it mentions "H265" or "HEVC" at least once. If not, you will not be able to use H265 but as long as you have H264, you still can use Shadow on Linux.

The following result show that the GPU is well recognized and have both profiles wanted. The relevant information are highlighted.

libva info: VA-API version 1.1.0 libva info: va_getDriverName() returns 0 libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so libva info: Found init function __vaDriverInit_1_1 libva info: va_openDriver() returns 0 vainfo: VA-API version: 1.1 (libva 2.1.0) vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 2.1.0 vainfo: Supported profile and entrypoints VAProfileMPEG2Simple : VAEntrypointVLD VAProfileMPEG2Simple : VAEntrypointEncSlice VAProfileMPEG2Main : VAEntrypointVLD VAProfileMPEG2Main : VAEntrypointEncSlice VAProfileH264ConstrainedBaseline: VAEntrypointVLD VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice VAProfileH264ConstrainedBaseline: VAEntrypointEncSliceLP VAProfileH264ConstrainedBaseline: VAEntrypointFEI VAProfileH264ConstrainedBaseline: VAEntrypointStats VAProfileH264Main : VAEntrypointVLD VAProfileH264Main : VAEntrypointEncSlice VAProfileH264Main : VAEntrypointEncSliceLP VAProfileH264Main : VAEntrypointFEI VAProfileH264Main : VAEntrypointStats VAProfileH264High : VAEntrypointVLD VAProfileH264High : VAEntrypointEncSlice VAProfileH264High : VAEntrypointEncSliceLP VAProfileH264High : VAEntrypointFEI VAProfileH264High : VAEntrypointStats VAProfileH264MultiviewHigh : VAEntrypointVLD VAProfileH264MultiviewHigh : VAEntrypointEncSlice VAProfileH264StereoHigh : VAEntrypointVLD VAProfileH264StereoHigh : VAEntrypointEncSlice VAProfileVC1Simple : VAEntrypointVLD VAProfileVC1Main : VAEntrypointVLD VAProfileVC1Advanced : VAEntrypointVLD VAProfileNone : VAEntrypointVideoProc VAProfileJPEGBaseline : VAEntrypointVLD VAProfileJPEGBaseline : VAEntrypointEncPicture VAProfileVP8Version0_3 : VAEntrypointVLD VAProfileVP8Version0_3 : VAEntrypointEncSlice VAProfileHEVCMain : VAEntrypointVLD VAProfileHEVCMain : VAEntrypointEncSlice

Install your drivers

Now that you understand how vainfo works, it is time to install the appropriate driver for your GPU. Sadly, there is not one driver and it depends on your GPU brand and model.

As it may change during time, we recommand you to read the documentation of the 2 main Linux distributions, especially the Arch Linux wiki because it is very complete: Arch Linux, Ubuntu.

But as we are so nice, the following table is a summary of all the main cases we encountered. If you meet some difficulties to install the drivers, please come in the official Discord so we can speak and let us help you.

Intel GPU

OS

< 8th gen

> 8th gen

Ubuntu

i965-va-driver

intel-media-va-driver-non-free

Arch Linux

intel-media-driver

libva-intel-driver

Solus

libva-intel-driver

x

NixOS

vaapiIntel

intel-media-driver

AMD GPU

OS

Radeon HD xxxx

Radeon Rxxx

Ubuntu

mesa-va-drivers

vdpau-va-driver

Arch Linux

libva-mesa-driver

mesa-vdpau

Solus

x

libvdpau-va-dl

NixOS

vaapiVdpau

libvdpau-va-dl

NVIDIA GPU

OS

NVIDIA < 800 series

NVIDIA > 800 series

Ubuntu

x

Check Arekinath's patch​

Arch Linux

nouveau-fw

​

Solus

x

x

NixOS

x

x

​

Source : https://nicolasguilloux.github.io/blade-shadow-beta/setup​

​

Installation chrome book

Tutoriel pour installer l'application Linux sur un Chromebook par @Mat€o Ce tutoriel est avancé mais bien expliqué. Pour toute question, hésitez pas à vous adresser à lui :wink: Pour sélectionner Linux au boot, faites CTRL + ALT + MAJ + Retour arrière Préférez le Log out lorsque vous quittez Linux

Source : Discord Shadow